Re: WISP628 problem


May 19, 2004

 


----------------------------

#5910 May 19, 2004

Hi



I have successfully used a homebuilt WISP628 for nearly 6 months

now. But just suddenly, now, when I try to program any pic I get an

error message like i>IOError: verification failure: different data

at

address 0034: file=85 target=80/i>. Then if I try to run the pic,

it

seems as if the old program was still in it.



Has anyone else had a similar problem to this?

Is there an easy solution to fix it?



Any suggestions are welcome

Thanks

Nick



----------------------------

#5912 May 20, 2004

I have successfully used a homebuilt WISP628 for nearly 6 months

> now. But just suddenly, now, when I try to program any pic I get an

> error message like i>IOError: verification failure: different data

> at

> address 0034: file=85 target=80/i>. Then if I try to run the pic,

> it

> seems as if the old program was still in it.

>

> Has anyone else had a similar problem to this?

> Is there an easy solution to fix it?



More details please, like target chip, maybe attach the .hex file?



Wouter van Ooijen



---------------

Van Ooijen Technische Informatica: www.voti.nl

consultancy, development, PICmicro products



----------------------------

#5913 May 20, 2004

Hi



I have tried to program these PICs just with the blink an LED code :

16F84A, 16F628, 18F242 and 18F252.

Each time I try to program the PIC I get that message.

If I read the code back from the pic it is just the code that was in

the pic before I started having this problem (I compared it with my

backup code).



Anyway, here is the HEX code I was previously trying to get into a

18F242.

:020000040000FA

:0A0000001AEF00F027EF00F014D013

:08001800D8CF81F0E8CF80F0A1

:10002000E0CF82F082C0E0FF80C0E8FF81C0D8FF4F

:1000300010001100826A000E946E816AFF0E936EAA

:10004000000E826E1200828C8288829E1200850EC3

:10005000740E81B6E80E826E000000000000000001

:0A00600000000000000027EF00F090

:020000040030CA

:0E000000FFFAFDFEFFFEFAFFFFFFFFFFFFFF0E

:00000001FF



Nick



--- In piclist@yahoogroups.com, "Wouter van Ooijen" wouter@v...>

wrote: > > I have successfully used a homebuilt WISP628 for nearly 6 months

> > now. But just suddenly, now, when I try to program any pic I

get an > > error message like i>IOError: verification failure: different

data > > at

> > address 0034: file=85 target=80/i>. Then if I try to run the

pic, > > it

> > seems as if the old program was still in it.

> >

> > Has anyone else had a similar problem to this?

> > Is there an easy solution to fix it?

>

> More details please, like target chip, maybe attach the .hex file?

>

> Wouter van Ooijen

>

---------------

> Van Ooijen Technische Informatica: www.voti.nl

> consultancy, development, PICmicro products



----------------------------

#5914 May 20, 2004

I have tried to program these PICs just with the blink an LED code :

> 16F84A, 16F628, 18F242 and 18F252.



After the failure message, what is the voltage on the target's MCLR pin?



Wouter van Ooijen



---------------

Van Ooijen Technische Informatica: www.voti.nl

consultancy, development, PICmicro products



----------------------------

#5915 May 20, 2004

--- In piclist@yahoogroups.com, "Wouter van Ooijen" wouter@v...>

wrote: > > I have tried to program these PICs just with the blink an LED

code : > > 16F84A, 16F628, 18F242 and 18F252.

>

> After the failure message, what is the voltage on the target's MCLR

pin?



The voltage is about 12.6V

>

> Wouter van Ooijen

>

---------------

> Van Ooijen Technische Informatica: www.voti.nl

> consultancy, development, PICmicro products


S
e
n
i
o
r
T
u
b
e
.
o
r
g