Re[3]: [MaxImDL] ASCOM hubs and application connections


Mar 7, 2004

 


----------------------------

#10370 Mar 7, 2004

I have installed the ASCOM platform. I have also MaxIm DL/CCD ver 3 and

The Sky version 5. I'm trying to control a classic LX200 scope over the

same serial port. In the past I have used multiple PCs and both serial

connections into the LX200 but hope to be able to do all from one

machine now. From a post to another list I have found that I need to

use hubs to allow both The Sky and MaxIm to control the LX200 at the

same time.



Is there some documentation that will help me understand hubs, how to

start them, and how to attach my applications to them? I eventually want

to include FocusMax into the mix but for now I would like to keep things

simple until I feel more comfortable with this set up.



I'm the newest of the newbies to ASCOM



Thanks Cliff





[Non-text portions of this message have been removed]



----------------------------

#10371 Mar 7, 2004

----- Original Message -----

From: "Clifford PETERSON" cpeterson@...>

To: MaxImDL@yahoogroups.com>

Sent: Sunday, March 07, 2004 6:40 PM

Subject: [MaxImDL] ASCOM hubs and application connections





> I have installed the ASCOM platform. I have also MaxIm DL/CCD ver 3 and

> The Sky version 5. I'm trying to control a classic LX200 scope over the

> same serial port. In the past I have used multiple PCs and both serial

> connections into the LX200 but hope to be able to do all from one

> machine now. From a post to another list I have found that I need to

> use hubs to allow both The Sky and MaxIm to control the LX200 at the

> same time.

>

> Is there some documentation that will help me understand hubs, how to

> start them, and how to attach my applications to them? I eventually want

> to include FocusMax into the mix but for now I would like to keep things

> simple until I feel more comfortable with this set up.

>

> I'm the newest of the newbies to ASCOM

>

> Thanks Cliff

>

>

> [Non-text portions of this message have been removed]

>

>

>

>

> Yahoo! Groups Links

>

>

>

>

>



----------------------------

#10372 Mar 7, 2004

Cliff,



You are correct that you need a hub to have TheSky and MaxIm control the

LX-200 at the same time. The two free Telescope hubs are FocusMax and POTH.

Since you are planning to use FocusMax eventually I will explain how to use

the FocusMax Telescope hub to do what you want. If you want to use POTH

instead simply substitute POTH wherever FocusMax appears.



FocusMax:

Telescope = "Meade Telescope and Focuser"

Focuser = "Meade Telescope and Focuser" if you want to do autofocus



MaxIm:

Telescope = "FocusMax Telescope Hub"

Focuser = either "none" or "FocusMax Focuser Hub"



TheSky:

follow instructions in file:

C:\Program Files\Common Files\ASCOM\Telescope\Planetarium

Plug-Ins\TheSky\install.txt

for instruction (3) choose the Telescope to be: "FocusMax Telescope Hub"



That should do it.



Larry











Clifford PETERSON wrote:



> I have installed the ASCOM platform. I have also MaxIm DL/CCD ver 3 and

> The Sky version 5. I'm trying to control a classic LX200 scope over the

> same serial port. In the past I have used multiple PCs and both serial

> connections into the LX200 but hope to be able to do all from one

> machine now. From a post to another list I have found that I need to

> use hubs to allow both The Sky and MaxIm to control the LX200 at the

> same time.

>

> Is there some documentation that will help me understand hubs, how to

> start them, and how to attach my applications to them? I eventually want

> to include FocusMax into the mix but for now I would like to keep things

> simple until I feel more comfortable with this set up.

>

> I'm the newest of the newbies to ASCOM



----------------------------

#10374 Mar 7, 2004

Cliff,



Larry is the expert. Glad to see you got your answer. I'll only add that

POTH stands for "Plain Old Telescope Hub." A hub and nothing but a hub ;-)



Gary





> -----Original Message-----

> From: Larry Weber [mailto:larryweber@...]

> Sent: Sunday, March 07, 2004 7:04 PM

> To: MaxImDL@yahoogroups.com

> Subject: Re: [MaxImDL] ASCOM hubs and application connections

>

>

> Cliff,

>

> You are correct that you need a hub to have TheSky and MaxIm control the

> LX-200 at the same time. The two free Telescope hubs are

> FocusMax and POTH.

> Since you are planning to use FocusMax eventually I will explain

> how to use

> the FocusMax Telescope hub to do what you want. If you want to use POTH

> instead simply substitute POTH wherever FocusMax appears.

>

> FocusMax:

> Telescope = "Meade Telescope and Focuser"

> Focuser = "Meade Telescope and Focuser" if you want to do autofocus

>

> MaxIm:

> Telescope = "FocusMax Telescope Hub"

> Focuser = either "none" or "FocusMax Focuser Hub"

>

> TheSky:

> follow instructions in file:

> C:\Program Files\Common Files\ASCOM\Telescope\Planetarium

> Plug-Ins\TheSky\install.txt

> for instruction (3) choose the Telescope to be: "FocusMax

> Telescope Hub"

>

> That should do it.

>

> Larry

>

>

>

>

>

> Clifford PETERSON wrote:

>

>

> > I have installed the ASCOM platform. I have also MaxIm DL/CCD ver 3 and

> > The Sky version 5. I'm trying to control a classic LX200 scope over the

> > same serial port. In the past I have used multiple PCs and both serial

> > connections into the LX200 but hope to be able to do all from one

> > machine now. From a post to another list I have found that I need to

> > use hubs to allow both The Sky and MaxIm to control the LX200 at the

> > same time.

> >

> > Is there some documentation that will help me understand hubs, how to

> > start them, and how to attach my applications to them? I eventually want

> > to include FocusMax into the mix but for now I would like to keep things

> > simple until I feel more comfortable with this set up.

> >

> > I'm the newest of the newbies to ASCOM

>

>

>

>

>

> Yahoo! Groups Links

>

>

>

>

>







----------------------------

#10377 Mar 8, 2004

Thanks to everyone that responded and Larry Weber in particular.



Because of your guidance I can now control everything from one machine.

In the past I have used multiple PC's or laptops and both RS232 ports on

the LX200 to control things. Although this is sometimes nice at home, it

get gets very kludgy in a remote location where everything is run from

two batteries.



Life is better now



Cliff





[Non-text portions of this message have been removed]



----------------------------

#10432 Mar 10, 2004

Larry (or anyone else),

I have a similar setup to Cliff - TheSky vers 5.00.102, MaxIm

3.2, FocusMax 3.1.3 and Robofocus.

With only FocusMax open, I followed your guidance but get an error

message when I try to set the Telescope = "Meade Telescope and

Focuser".

As soon as I click on the "Select" button in "Telescope" I get

a "Helper" message saying "Run-Time error '-2147220416 (80040440)':

Failed to open sub-key Chooser"

When I click OK I get Run-time error '440': Automation error"

When I click OK on that I get "Run-time error '13': Type mismatch"



Am I missing something?



Regards,



Kevin











--- In MaxImDL@yahoogroups.com, "Larry Weber" larryweber@i...> wrote:

> Cliff,

>

> You are correct that you need a hub to have TheSky and MaxIm

control the

> LX-200 at the same time. The two free Telescope hubs are FocusMax

and POTH.

> Since you are planning to use FocusMax eventually I will explain

how to use

> the FocusMax Telescope hub to do what you want. If you want to use

POTH

> instead simply substitute POTH wherever FocusMax appears.

>

> FocusMax:

> Telescope = "Meade Telescope and Focuser"

> Focuser = "Meade Telescope and Focuser" if you want to do

autofocus

>

> MaxIm:

> Telescope = "FocusMax Telescope Hub"

> Focuser = either "none" or "FocusMax Focuser Hub"

>

> TheSky:

> follow instructions in file:

> C:\Program Files\Common Files\ASCOM\Telescope\Planetarium

> Plug-Ins\TheSky\install.txt

> for instruction (3) choose the Telescope to be: "FocusMax

Telescope Hub"

>

> That should do it.

>

> Larry

>

>

>

>

>

> Clifford PETERSON wrote:

>

>

> > I have installed the ASCOM platform. I have also MaxIm DL/CCD ver

3 and

> > The Sky version 5. I'm trying to control a classic LX200 scope

over the

> > same serial port. In the past I have used multiple PCs and both

serial

> > connections into the LX200 but hope to be able to do all from one

> > machine now. From a post to another list I have found that I

need to

> > use hubs to allow both The Sky and MaxIm to control the LX200 at

the

> > same time.

> >

> > Is there some documentation that will help me understand hubs,

how to

> > start them, and how to attach my applications to them? I

eventually want

> > to include FocusMax into the mix but for now I would like to keep

things

> > simple until I feel more comfortable with this set up.

> >

> > I'm the newest of the newbies to ASCOM



----------------------------

#10434 Mar 10, 2004

Kevin,



Have you installed the latest ASCOM Platform? It sounds like it is somehow

messed up.



Can you successfully Choose the "Telescope Simulator" ?



Larry







Kevin wrote:

> Larry (or anyone else),

> I have a similar setup to Cliff - TheSky vers 5.00.102, MaxIm

> 3.2, FocusMax 3.1.3 and Robofocus.

> With only FocusMax open, I followed your guidance but get an error

> message when I try to set the Telescope = "Meade Telescope and

> Focuser".

> As soon as I click on the "Select" button in "Telescope" I get

> a "Helper" message saying "Run-Time error '-2147220416 (80040440)':

> Failed to open sub-key Chooser"

> When I click OK I get Run-time error '440': Automation error"

> When I click OK on that I get "Run-time error '13': Type mismatch"

>

> Am I missing something?



----------------------------

#10666 Mar 30, 2004

Hello Larry,



Some time ago but I just got round to trying this myself........



All goes fine until I try to connect The Sky to the FocusMax Telescope

Hub. I can choose the setting but the OK button is greyed out. I have

copied the file over as directed in the install.txt. Any ideas what

I'm doing wrong.



Monday, March 8, 2004, 1:03:45 AM, you wrote:



LW> Cliff,



LW> You are correct that you need a hub to have TheSky and MaxIm control the

LW> LX-200 at the same time. The two free Telescope hubs are FocusMax and POTH.

LW> Since you are planning to use FocusMax eventually I will explain how to use

LW> the FocusMax Telescope hub to do what you want. If you want to use POTH

LW> instead simply substitute POTH wherever FocusMax appears.



LW> FocusMax:

LW> Telescope = "Meade Telescope and Focuser"

LW> Focuser = "Meade Telescope and Focuser" if you want to do autofocus



LW> MaxIm:

LW> Telescope = "FocusMax Telescope Hub"

LW> Focuser = either "none" or "FocusMax Focuser Hub"



LW> TheSky:

LW> follow instructions in file:

LW> C:\Program Files\Common Files\ASCOM\Telescope\Planetarium

LW> Plug-Ins\TheSky\install.txt

LW> for instruction (3) choose the Telescope to be: "FocusMax Telescope Hub"



LW> That should do it.



LW> Larry







--

Best regards,

John mailto:kvp@...







----------------------------

#10667 Mar 30, 2004

The OK button is grayed out until you confirm the Properties... (COM Port

settings, etc., for "real" scopes, not for hubs). Once you click

Properties..., confirm that your chosen telescope (or hub) is set up

properly (may not need any settings), the OK button will be lit.



-- Bob



John Parkins: > Hello Larry,

>

> Some time ago but I just got round to trying this myself........

>

> All goes fine until I try to connect The Sky to the FocusMax Telescope

> Hub. I can choose the setting but the OK button is greyed out. I have

> copied the file over as directed in the install.txt. Any ideas what

> I'm doing wrong.



----------------------------

#10675 Mar 30, 2004

Hello Bob,



Sorry Bob but I don't understand this. If I click on Properties I

eventually get an error from the ASCOM chooser telling that "Failed to

load driver: Object required"





Tuesday, March 30, 2004, 5:45:32 PM, you wrote:



BD> The OK button is grayed out until you confirm the Properties... (COM Port

BD> settings, etc., for "real" scopes, not for hubs). Once you click

BD> Properties..., confirm that your chosen telescope (or hub) is set up

BD> properly (may not need any settings), the OK button will be lit.



BD> -- Bob





--

Best regards,

John mailto:kvp@...



----------------------------

#10676 Mar 31, 2004

Hello,



Answering my own post........



I have since been told about a utility called "Fix FocusMax and

TheSky" which seems to have solved my problems. I now have TheSky

attached to the FocusMax Hub.





Wednesday, March 31, 2004, 7:40:35 AM, you wrote:



JP> Hello Bob,



JP> Sorry Bob but I don't understand this. If I click on Properties I

JP> eventually get an error from the ASCOM chooser telling that "Failed to

JP> load driver: Object required"





JP> Tuesday, March 30, 2004, 5:45:32 PM, you wrote:



BD>> The OK button is grayed out until you confirm the Properties... (COM Port

BD>> settings, etc., for "real" scopes, not for hubs). Once you click

BD>> Properties..., confirm that your chosen telescope (or hub) is set up

BD>> properly (may not need any settings), the OK button will be lit.



BD>> -- Bob











--

Best regards,

John mailto:kvp@...



Contact Us
This Site's Privacy Policy
Google's privacy policies

S
e
n
i
o
r
T
u
b
e
.
o
r
g